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Registration
Easy Menu for Windows requires registration.  The registration fee is $20.  The

license upgrade fee from earlier versions is $7.50.  (Upgrade is free if you licensed 
version 3.1 after July 1, 1992.)  Site licenses are available for multiple copies.  The 
fees are:

Copies Fee

1 to 10 $20.00 each
11 to 30 $15.00 each for first 10 copies, $10.00 each for copies in excess of 10
31 or more $15.00 each for first 30 copies, $7.50 each for copies in excess of 30

To register, send your payment (cash, money order, or check in U.S. funds) with the 
order form included in the distribution file (ORDER.TXT).  The order form may also be 
used to purchase an Easy Menu for Windows diskette or printed user's manual.  Send 
your order to:

Glen S. Tittermary
P.O. Box 1641

Richmond, Virginia 23213

Software License Agreement
Easy Menu for Windows is furnished only on the condition that the purchaser agrees 
to the following terms and conditions:

1.  Easy Menu for Windows remains the property of the author, but the author grants 
the purchaser a nonexclusive license to use it subject to this agreement.

2.  The purchaser agrees not to copy, disassemble, or alter the software without 
permission of the author.

3.  If the software does not perform as described in this manual, the purchaser's 
license fee shall be returned if the author is notified in writing.  The author assumes 
no liability for any damage or loss caused by the use of this software.  This software 
is provided "as is" without any warranty of any kind, either expressed or implied.

Easy Menu for Windows
Versions 3.2 and LT

Released January 1993
Copyright (c) 1990 - 1993 by Glen S. Tittermary
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1.  Introduction

General Description

Easy Menu for Windows is a menu system for Microsoft Windows 3.X.  It makes
user-defined applications available with a single click of the mouse or press of a key.  
In addition, it makes all of the Windows Desktop Accessories or user-defined 
accessories available on the same menu.  Applications may be Windows applications 
or DOS programs.  Version 3.2 is fully compatible with Windows 3.1  and later (and 
will not run under previous versions of Windows).  Easy Menu 3.2 runs only in 
Standard and Enhanced mode.  Easy Menu for Windows has complete keyboard 
support, so it is an excellent Windows applications manager for laptops and other 
systems without a mouse.

Program Features

This version of Easy Menu includes support for start-up directories for each 
menu item, and each item can be started as either a window, icon, or full screen.  
New in this version is support for file handling -- no more need to start the File 
Manager for simple file copies, moves, etc.
 

Version 3.2 includes the Easy Menu Editor, which makes maintenance of your 
menus quick and convenient.  With the editor, you can clear, insert, and delete menu
items.  The editor also provides printer support, so all of the menu data can be 
printed.  Some of the features of Easy Menu include:

Start all of the Windows desktop accessories from the menu

Start the Program and File Managers from the menu

Run applications from a command line

Minimize the menu on start of applications

Specify the Windows start-up shell

Specify applications to auto-start when Windows is loaded

Complete keyboard support for all features -- great for laptops

Command Bar -- pushbuttons for changing menus, accessories menu
on/off, menu editor, update menus, and exit

Menu Editor -- insert, delete, clear items -- undo edits -- print 
menu data -- test menu item data

Complete directory support -- specify start-up directory for each 
application

Specify whether an application will start as a window, an icon, or full 

4



screen

Replace Windows Accessory menu with user-defined accessory menu

Complete error checking and reporting

Save the menu window position

System info dialog box -- reports Windows version, operating mode, 
free memory, disk space, etc.

Start Easy Menu with list of menus

Specify initial file for the Windows accessories

Password protection and system locking

Support for up to 300 menu items organized in 5 groups

A Command/Information Bar to support changing groups and
menus, display of date/time, free disk space, and free memory

Specify an alternate file manager

File utilities to copy, move, delete and rename files on your hard disk

Organizing Your Menus

With Easy Menu 3.2 you can construct up to five menu groups, each with six 
independent menus with 10 items each, for a maximum of 300 menu items.  How 
you organize the groups, menus, and items in your menus will have a lot to do with 
how easy and convenient Easy Menu is to use.  There are many ways to organize the 
menus, so the decision on what is best for you will depend on your specific situation. 
The suggested organizations below are only some of the ways you might want to 
consider.

Menu Groups.  Menu groups are designed to give you more flexibility in 
organzing your menus.  If you need to start more than 60 applications you can create
groups of menus, giving you up to 300 menu choices.  Easy Menu 3.2 supports up to 
five groups of six menus each.  Creating multiple groups will also be useful if more 
than one person uses a computer -- each person can be given their own group of 
menus.  Within each group, you can also provide some organization to the menus as 
described in the following paragraphs.

Organizing by Type of Application.  One way to set up the Easy Menu 
menus is to have each menu contain different types of applications.  Menu 1 might 
contain word processing and text editing applications, for example, while Menu 2 
could contain speadsheet and database programs.  Menu 3 could have drawing, 
graphics, and presentation applications.  Menu 4 might contain entertainment and 
game programs.  The menu names for these four menus would describe the types of 
applications they contain:  Word Processing, Data Analysis, Drawing and Presentation 
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Tools, and Entertainment.

Organizing by Task.  Another way to organize your menus is by the tasks 
you complete.  This type of organization is useful if you want to use the same 
applications for several menu items, but with different start-up files (as command line
parameters) or start-up directories.  For example, a small consulting firm might have 
one menu for each current project.  Each menu would contain a word processing 
menu item, a project management item, a speadsheet item, and a desktop 
presentation item.  The menu items would have different start-up directories which 
were created for the exclusive use of the appropriate project.  So, when the 
applications are started, the current working directory would be the directory for the 
desired project.

Organizing Sequentially.  If you do not have many applications, it may be 
more useful to simply list the applications alphabetically in the first couple of menus. 
When the first menu is full, go on to the next and continue with the listing.  With the 
menu scroll buttons on the Command Bar (see Using Easy Menu for Windows below) 
this can be a quick and easy way to access the menu items.

Quick Setup

To configure Easy Menu for Windows for your system, you will need to:  (1) 
install the program files and start Easy Menu, (2) enter the information for the 
menus, and (3) update the menu listings in Easy Menu.

Install the Program Files and Start Easy Menu.  Easy Menu is distributed 
as a ZIP file.  To install the necessary files you need to "unzip" the files to your 
Windows directory.  The following files are included in the distribution ZIP file:

menu.exe Main Easy Menu program
menult.exe The "Lite" version of Easy Menu
menuedit.exe Menu editor program
mconvert.exe Program to convert version 2.0 files to 3.0/3.1/3.2
menu.wri This user's manual
order.txt Order form for license, diskette, manual, or 

upgrade

The file "menu.ini" is created the first time you run Easy Menu for Windows (unless 
you are using an earlier version).

After the program files have been placed in your Windows directory, start Easy
Menu from the Program Manager or the File Manager by executing the file menu.exe. 
When the program starts a dialog box will be displayed requesting a license number.  
Until you receive a license, click Cancel and the Easy Menu window will be displayed.
You are now ready to enter the menu data.

Important Note for Easy Menu Version 2.0 Users:  Easy Menu 3.2 uses
a new file format for the menu data.  Users of version 2.0 will need to run 
MCONVERT.EXE to convert their menu.ini file to the new format.  You do not 
have to retype your menus  -- the Mconvert program will make all of the necessary 
changes for you.  To make the conversion, start Easy Menu as usual.  All of the menu 
items should be "Reserved."  Select Quick Run... from the Menu menu and when 
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the Quick Run... dialog box appears, enter mconvert.exe and click the OK button.  
When the Easy Menu Menu File Conversion program starts, select Convert! from the 
menu.  After the conversion is complete, close the conversion program and select 
Update Menus from the Menu menu in Easy Menu.  Your menus will be ready to use,
so you can skip the next two steps of the quick setup.  

Set up the Menu Items.  Start the Easy Menu Editor to set up the 
applications to be run from  each of the six menus.  To start the editor, select the 
Menu Editor... item under the Menu menu.  (Note:  The Editor is a separate 
program, so you can also start it from the Program Manager or File Manager; the file 
name is menuedit.exe.)  When the Editor starts, the six menus for the currently 
selected group (Group A when you first start)  will be listed in the main window.  You 
can select the menu you want to edit by clicking anywhere on the menu listing with 
the left mouse button.  Or, you can use the arrow keys to select the menu to be 
edited.  The selected menu will have a red border around it.

After you have selected the menu you want to edit, select Edit... from the 
Menu menu.  The Menu Items... dialog box will appear.  First, select the Menu 
Name field (with the mouse or the TAB key) and type the name of the menu.  The 
name will appear in the Easy Menu Menu pull-down menu and in the Easy Menu for 
Windows title bar.  You should make the name descriptive, but not too long.  A 
maximum of 40 characters is permitted.

Now you are ready to set up the applications to be run from the menu.  Easy 
Menu for Windows can start up to ten applications in each menu.  Applications are 
loaded according to the information you supply in the Menu Items... dialog box.  For
each application, you enter a label, a command line, a start-up directory, and 
whether you want the application to start as a window, icon, or full screen.

The label is the name of the application that you want to appear next to the 
button in the menu.  The label can be up to 20 characters long.  For example, the 
label for Microsoft Excel might be MS Excel.

The command line consists of the executable program to be run, and any 
optional parameters.  For example, to run Microsoft Excel, you would enter the 
command line:  excel.exe.  To start Excel with a spreadsheet named "budget.xls" 
loaded on start-up, the command line would be:  excel.exe budget.xls.  The 
command line can be up to 80 characters long.

The start-up directory is the directory you want to use as the working 
directory when the application starts.  For example, if Excel is in the directory "c:\
excel," but your spreadsheets are in a directory called "data" on drive c:, you could 
specify a start-up directory as:  c:\data.  When Excel is started, the "data" directory 
would be active (when you open or save files, for example).  The start-up directory is 
also useful for DOS programs that use configuration files, or for files that are in 
directories that have not been included in your PATH statement.

Finally, select the way you want the application to start:  as a window, an icon,
or as the full screen.  When using a mouse, just click the radio button for your 
selection.  If you are using the keyboard, use the TAB key to move to the Start as... 
group, and then use the arrow keys to select the start-up mode.
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Use the Next pushbutton to advance to the next menu item.  Enter the data 
for the item, and continue for as many menu items as you want.  When all of the 
menu items have been entered, click the Save button to save your menu data to the 
"menu.ini" file.  The menu data you have entered will be lost if you exit 
without saving it.  After you have saved your data, the Menu Items... dialog box 
will be closed.  Now you can Exit the editor.

Update the Menus.  When you return to Easy Menu for Windows from the 
editor, your changes will not appear on the menu.  To apply the edit you have made, 
select the Update Menus item under the Menu menu.  Easy Menu will show the 
labels you entered in the Easy Menu Editor.  You are now ready to use Easy Menu to 
start the applications.  (For more information on how to use the editor, see section 3 
of the user's manual.)
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2.  Using Easy Menu for Windows
The Easy Menu for Windows Window

The Easy Menu for Windows window has six major parts, as described in the 
paragraphs below.  You use different parts of the the window to accomplish different 
tasks.

The Title Bar.  At the top of the window is the title bar, along with the system
box and a minimize button.  The title bar will always show the group letter (A,B,C, 
etc.) and menu name of the currently selected menu.

The Menu Bar.  The menu bar has five items.  The File item is used to copy, 
move, and otherwise manage files on your hard disk, to display the dialog box in 
which you can enter a command line to execute applications, and includes the 
system information and About menu items.  The Group item is used to select the 
current group of menus and to exit the program (or to exit Windows if Easy Menu is 
the system shell).  The Menu item is used to select  a menu, to start the Easy Menu 
Editor, to update the menus after they have been edited.  The Accessories item is 
used to start each of the Windows Desktop Accessories or the user-defined 
accessories.  The Options item is used to select various options which control how 
Easy Menu looks and operates:  the Windows Accessories and User Accessories 
items toggle the accessories menu between the Windows Desktop Accessories and a 
set of user-defined accessories; the accessories pushbutton menu can be turned on 
or off; Easy Menu can be minimized to an icon each time an application is run; and 
the Easy Menu position on the screen can be saved.  Also, you can specify an 
optional password for protection of your system and data.

The Command/Information Bar.  Below the menu bar is the 
Command/Information Bar.  The Command Bar has 12 pushbuttons which can be 
used to execute frequently used commands.  Two sets of arrow buttons, < and >, are
at the left end of the Command Bar.  The top set is labelled "Group:" and is used to 
scroll from one menu group to the next.  The lower set is labelled "Menu:" and is for 
scrolling through the six menus in the currently selected group.

The remaining four buttons on the upper row of the Command Bar are E, U, Q,
and !.  The E button is for starting the Easy Menu Editor, and the U button updates 
the menus after they have been edited.  The Q button displays the Quick Run... 
dialog box for starting applications not on your menus.  The ! button locks the system
and displays a dialog box for entering your password to unlock the system.  (The ! 
button will be disabled if no password is active.)

The lower set of four buttons are w|u (or u|w), - (or +), X, and C: (or D:, E:, 
etc.).  The w|u (u|w) button is used to toggle between the Windows or user-defined 
accessories.  this button will be disabled if the accessories pushbutton menu is 
turned off.  The +/- button is for turning the accessories pushbutton menu on and off.
The X button exits the program (or exits Windows if Easy Menu is the system shell).  
The C: (or D:, E:, etc.) button is used to select the drive to be used for the free disk 
space display.  The button label will change to show the drive currently selected.
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The right-hand side of the Command Bar displays the current date and time in
the upper row.  Below the date/time display are the amount of free disk space for the 
currently selected drive, and the amount of free system memory.

The Applications Menu.  The next portion of the Easy Menu window is the 
Applications Menu.  The Applications Menu consists of the ten pushbuttons used to 
start the applications that you specify.  The applications are defined with the Easy 
Menu Editor.

The Manager Menu.  Below the Applications Menu is the Manager Menu.  
This portion of the Easy Menu window has two buttons for starting the Windows 
Program Manager and File Manager.  With Version 3.2, you can specify an alternate 
file manager.  See the instructions for the Menu Editor to use this feature.

The Accessories Menu.  The bottom portion of the window is the 
Accessories Pushbutton Menu.  This menu is used to start each of the Windows 
Desktop Accessories or the user accessories.  The accessories pushbutton menu can 
be turned on or off as you prefer.

Entering Your License  

Use the order form included with Easy Menu to order your license number.  
When you obtain your license, start Easy Menu and the Enter License... dialog box 
will appear.  (The license number removes the license dialog box which appears when
Easy Menu for Windows is started.)  When the Enter License... dialog box appears, 
type your license number exactly as it appears on  your registration notification 
(capital letters must be typed as capitals, etc.).  If you are using a mouse, click the 
OK button.  If you are using the keyboard, press the TAB key to select the OK button,
then press the SPACE BAR.  (Note:  After Easy Menu has been started, you can also 
enter your license by selecting the Enter License... item from the Options menu.)

Working with Files

The first item on the Easy Menu menu bar is the File item.  The File menu is 
used to run, copy, move, delete, rename, or view files on your hard disk on floppy 
diskettes.  Also, this menu is used to create subdirectories on your hard disk. 

Running an Application not on the Menu.  On occasion you may want to 
run an application not on your Applications Menu.  To do this, select the Quick Run...
item from the File menu.  Or, you can click the Q button on the Command Bar.  If you
are using only the keyboard, press the [Q] key.  When the Quick Run... dialog box 
appears, type the command line you want and click the OK button or press the 
RETURN key.

 Copying and Moving Files.  To copy or move  a file, select the Copy/Move 
item from the File menu.  The File Copy/Move dialog box will be displayed.  Select 
the file to copy by highlighting it in the list box in the lower left hand portion of the 
dialog box, and then click the Select File button.  You can move from one directory 
to another within the list box by highlighting the name of the directory and clicking 
the Change Directory button.  The name of the selected file will be displayed in the 
From: text box at the top of the dialog, and the To: list box in the lower right hand 
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portion of the dialog will be enabled.  The From: list box will be disabled.  Select the 
drive and directory where you want to copy the file to.  You can move to other 
directories by highlighting the directory name and clicking the Change Directory 
button.  The currently selected directory will be displayed in the To: text box at the 
top of the dialog.  To carry out the copy operation, click the Execute button.  After 
the copy is complete a message box will notify you.

If you make a mistake in specifying any of the information for the copy you 
can clear all your entries and start over by clicking the Reset button.  After you have 
copied all the files, click on Close to return to Easy Menu.

To move a file, follow the steps above for copying a file, but click the Move 
radio button before clicking the Execute button.

Deleting Files.  To delete a file select Delete from the File menu.  The File 
Delete dialog box will be displayed.  Type the name of the file to be deleted in the 
edit box and click the Delete button.  If you do not know the exact name of the file, 
click the Browse button for a list box with all the files in the currently selected 
directory.  Highlight the file to be deleted and click the Select File button.  The file 
name will be copied to the File Name: edit box.  Click the Delete button to delete 
the file.

Note that you can delete a file only in the current directory, which is shown 
above the edit box for the file name.  If you need to change directories, click on the 
Browse button to display the file list box.  Highlight the directory you want and click 
the Change Directory button.  You can also change drives with the Drives: combo 
box.

Renaming Files.  To rename a file, select Rename from the File menu.  The 
Rename File dialog will be displayed.  Type the file's current name in the From: edit 
box at the top of the dialog.  Move to the To: edit box (by pressing the [TAB] key or 
clicking the box with the mouse) and type the new file name.  Click the Rename 
button to carry out the rename operation.  If you do not know the exact name of the 
file to rename, click the Browse button for a list box of files in the current directory.  
Select the file to be renamed by highlighting it and clicking the Select File button.  
The file name will be copied to the From: edit box and the focus moved to the To: 
edit box ready for the new file name.

Note that you can rename a file only in the current directory, which is shown 
above the edit box for the file name.  If you need to change directories, click on the 
Browse button to display the file list box.  Highlight the directory you want and click 
the Change Directory button.  You can also change drives with the Drives: combo 
box.

Viewing Text Files.  To view the contents of a text file, select View from the 
File menu.  The View File dialog will be displayed.  Type the name of the file you 
want to view and click the View button.  A window with the contents of the file will be
displayed.  The file will be displayed in blocks of 8 Kb, with the proportion currently 
displayed shown as a horizontal bar at the top of the dialog.  Also shown are the file 
name and file size.  You can scroll through the blocks (if more than one) by clicking 
the <<PgUp and PgDn>> buttons.  Use the standard scroll bar to scroll through the 
contents in the text window.  If you do not know the exact name of the file to view, 
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click the Browse button for a list box of files in the current directory.  Select the file 
to be viewed by highlighting it and clicking the Select File button.  The file name will
be copied to the File Name: edit box.  Click the View button to view the file.  The 
viewer works only with ASCII text files.

Note that you can view a file only in the current directory, which is shown 
above the edit box for the file name.  If you need to change directories, click on the 
Browse button to display the file list box.  Highlight the directory you want and click 
the Change Directory button.  You can also change drives with the Drives: combo 
box.

Creating a New Subdirectory.  To create a new subdirectory on your hard 
disk, select Create Directory from the File menu.  The Create Directory dialog 
box will be displayed.  The new directory will be created in the current directory, 
which is shown above the edit box at the top of the dialog.  Type the new 
subdirectory name in the edit box and click the Create button.  If you need to 
change to a different directory, click the Browse button to display a list box of the 
directories.  Select the directory you want and click the Change Directory button.  
The new directory will be displayed above the edit box.

Selecting a Menu Group

When Easy Menu first starts, Group A will be active.  You can change the 
active group from the Easy Menu menu bar, the Command Bar or the keyboard.  
Note:  To create or edit a group, use the Menu Editor.

Using the Menu.  To select a group using the Easy Menu menu, choose the 
Group item on the Easy Menu menu bar.  The groups which have been created will 
be displayed in the drop-down menu.  Select the group you want to load.  The 
currently selected group will have a check mark next to it.  When a new group is 
selected, the Easy Menu menus will be updated to display the menus associated with
the group.

Using the Command Bar.  To scroll through the available groups, click the 
Group < or > pushbuttons.

Using the Keyboard.   The keyboard can be used to scroll through the 
groups just as the < and > pushbuttons function in the Command Bar.  The PgUp 
and PgDn keys select the previous and next group respectively. 

Selecting a Menu

There are several ways to select a menu, or to change from one menu to 
another.  The most convenient for you will depend on how you are using the system 
and whether you have a mouse.

Using the Menu.  To select the menu you want to use, choose the Menu 
item in the Easy Menu for Windows menu bar.  Then click the menu you want.  A 
check mark will appear next to the currently selected menu.
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Using the Command Bar.  To scroll through each of the menus, click the 
Menu < or > pushbuttons in the Command Bar.

Using the Keyboard.  The keyboard can be used to scroll through the menus
just as the < and > pushbuttons function in the Command Bar.  The left and up arrow
keys select the previous menu; the right and down arrow keys select the next menu.

Starting Applications on the Applications Menu

You can start the applications on your menus with the mouse or the keyboard. 
The keyboard interface is especially useful for laptops and other systems which do 
not use a mouse.

Using the Mouse.  To start an application on the Applications Menu, click on 
the appropriate button.  Just click the button once -- don't double click as you would 
on the Program Manager.

Using the Keyboard.  If you are working without a mouse, you can start the 
application by pressing the number key corresponding to the button.  You may use 
either the number keys above the letters or the numeric keypad.

Selecting Windows Accessories or User Accessories

Easy Menu for Windows includes a menu for accessories.  The accessories are 
utility applications that are generally available to the user regardless of which of the 
six application menus may be displayed.  Easy Menu supports two types of 
accessories:  (1) those supplied with Windows, and (2) utilities which the user 
supplies from other sources.  The Windows Accessories include such utility programs 
as a clock, a cardfile, a paint program, a calculator, the control panel, etc.   User 
accessories might include a text editor, a graphics file viewer, a screen blanker, etc.  
And of course, you could define some of the Windows Desktop Accessories as user 
accessories also.  To define the user accessories you use the Menu Editor (described 
section 3 of this manual).

Using the Menu.  You can select between Windows Accessories and user 
accessories in the Options menu.  Select Windows Accessories... if you want the 
Accessories menu to include the 12 Desktop Accessories.  Select User 
Accessories... if you want the Accessories menu to include the nine accessories you
have defined.

Using the Command Bar.  You can toggle between the two types of 
accessories by clicking the w|u or u|w button.  When the Windows accessories are 
selected, the button shows w|u.  Clicking the button changes to the user accessories.
When the user accessories are active the button shows u|w.  Clicking the button now
switches back to the Windows accessories.

Using the Keyboard.  You can also toggle between the Windows and user-
defined accessories by pressing the [SPACEBAR] when Easy Menu is the active 
window.
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Turning the Accessories Menu On/Off

You can turn the Accessories pushbutton menu on or off as you prefer using 
the menu, Command Bar, or keyboard. 

Using the Menu.  The first time you start Easy Menu for Windows, the 
Accessories menu will be on.  To turn it off, select Accessories Menu from the 
Options menu.  This configuration will be saved, so the next time Easy Menu for 
Windows is started your preference will be used.  To turn the Accessories menu back 
on, select Accessories Menu again from the Options menu.

Using the Command Bar.  As an alternative, you can use the - pushbutton 
on the Command Bar to turn the Accessories Menu off.  The + pushbutton turns the 
Accessories Menu on.

Using the Keyboard.  If you are working without a mouse, the [+] and [-] 
keys can be used to turn the Accessories Menu on and off.

Note:  The pushbuttons for the Program Manager and the File Manager are 
always available, even with the Accessories Menu turned off.

Starting the Windows Desktop Accessories

If you have the Accessories menu configured for the Windows Desktop 
Accessories, you can start the accessories in several different ways.

Using the Accessories Pushbutton Menu.  To run a Windows Desktop 
Accessory from the pushbutton menu, click on the appropriate button on the 
Accessories Menu.

Using the Keyboard.  When the Accessories Menu is turned on, you can also
use the keyboard to start the accessories.  Press the letter key corresponding to the 
pushbutton.  The appropriate letter is the one underlined in the pushbutton.

Using the Menu.  If you prefer, the Desktop Accessories can be run by 
selecting the accessory from the Accessories menu on the Easy Menu menu bar.  
Even if you have the Accessories pushbutton menu turned off, the accessories can be
run from the pull-down menu.

Starting the User-Defined Accessories

If you have the Accessories menu configured for  accessories you have 
defined, you can start the accessories in several different ways.

Using the Accessories Pushbutton Menu.  To run a user-defined accessory
from the pushbutton menu, click on the appropriate button on the Accessories Menu.

Using the Keyboard.  When the Accessories Menu is turned on, you can also
use the keyboard to start the accessories.  Press the function key you assigned to the
accessory in the menu editor to start the accessory.  
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Using the Menu.  If you prefer, the user-defined accessories can be run by 
selecting the accessory from the Accessories menu on the Easy Menu menu bar.  
Even if you have the Accessories pushbutton menu turned off, the accessories can be
run from the pull-down menu.

Configuring Minimize on Run

You can make Easy Menu for Windows minimize to an icon each time you run 
an application or accessory  by selecting Minimize on Run from the Options menu. 
A check  mark will appear next to Minimize on Run when the option is active.  To 
turn it off, select it again.

Saving the Easy Menu Window Position

By default, the Easy Menu window will center itself on the screen.  You can 
override this default by moving Easy Menu to the position you want it on the screen 
and selecting Window Position Save under the Options menu.  The position you 
selected will be saved, and used whenever you start Easy Menu.  To return to the 
default, select Window Position Center from the Options menu.

Using System Security

The System Security... item on the Options menu provides several 
methods for you to protect your system and data.  You can set up password 
protection for various tasks, and you can set attributes for key system files.  These 
features provide basic security for your siystem, and can be especially useful if you 
are using a network or are in a  office in which others may have access to your 
computer.

Creating a Password.  To create a password, select System Security... 
from the Options menu.  The System Security... dialog box will be displayed.  Type
your password in the Password: edit box.  So that others cannot see what you type, 
asterisks will be shown in the edit box as you type.  Type carefully, because you will 
need to type your password exactly as you type it the first time whenever you are 
prompted for a password (the password is case sensitive, for example).

To activate the password you click the On radiobutton beside the edit box.  
This automatically applies the password to three tasks:  the System Security... 
dialog box, the Easy Menu Menu Editor, and the system lock.  You can disable the 
password at any time by clicking the Off radiobutton.

You can also optionally apply the password to the start-up of Easy Menu (and 
to Windows ifself if Easy Menu is the shell), the start-up of each application on the 
menu, the start-up of the Program and File Managers, and the use of the Windows 
and user accessories.  Note that if you apply the password to the Easy Menu start-up,
you will have to also type your password to close Easy Menu (or your Windows 
session if Easy Menu is the shell).  This is useful in preventing someone from ending 
your Windows session in order to get access to the DOS prompt.

Using Your Password.  After you have entered a password and turned it on, 
whenever you start a task to which the password has been applied you will be 
prompted for the password.  If you type it wrong, the computer will beep and you can
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try again.  If after three tries the correct password has not been entered, the task will 
be cancelled.  Remember, you must enter the password exactly as it was created -- 
capital letters must be entered as capitals, etc.

Protecting System Files.  The System Security... dialog box also provides 
a means to protect critical system files.  Five files can be made read-only and/or 
hidden:  config.sys, autoexec.bat, win.ini, system.ini, and menu.ini.  Making the files 
hidden will keep others from finding the files on directory listings.  Making them read-
only keeps them from being accidentally erased or modified.  Note, however, that 
making win.ini, system.ini, or menu.ini read-only means you will not be able to save 
any changes to your Windows configuration.  Also programs such as Excel and Word 
save their configurations to win.ini when they exit;  if win.ini is read-only protected, 
you may get an error message.  In addition, many programs must write to win.ini 
when they are installed.  Read-only protection should be turned off before installing 
any new applications in Windows.

Using the System Lock

On occasion, when you walk away from your desk, you may want to keep 
others from disturbing your work in a Windows application.  Easy Menu 3.1 makes it 
possible to lock your Windows session with the System Lock  dialog box.

Setting Up the Lock.  To use the system lock you first need to enter and 
turn on a password in the System Security... dialog box.  See the Using System 
Security section above for instructions on how to create and activate a password.

Activating the Lock.  Whenever Easy Menu is the active window, you can 
lock your system in any one of three ways.  To use the Easy Menu menu, select Lock 
System! from the Options menu.  To use the Command Bar, click the ! button.  Or 
you can use the keyboard by pressing the [PAUSE] key.

These actions will display the System Lock dialog box.  Once the System 
Lock dialog box is displayed, all other Windows processing is halted.  When the 
system is locked, no Windows or DOS applications can be accessed.  To resume 
operation, you must enter your password and click the OK button or press 
[RETURN].

Getting System Information

Sometimes it is necessary to get information about your system, such as how 
much free memory or disk space is currently available.  You can get a report on 
system information by selecting System Info... from the File menu.  The Easy 
Menu System Information dialog box opens and displays  the current version of 
Windows; whether Windows is operating in Standard or 386 Enhanced mode; the 
microprocessor type for your system; whether a math coprocessor is present in the 
system; the amount of free memory in the system; the percentage of free system 
resources; and the amout of free disk space on the currently selected drive.  Click the
OK button or press [RETURN] to close the dialog box. 

Exiting from Easy Menu for Windows

To exit, select Exit (or Exit Windows... if Easy Menu for Windows is the 
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system shell) from the File menu.  Or you can click the X pushbutton on the 
Command Bar.  If you are using the keyboard, you can just press the [X] key.  If Easy 
Menu is the sytem shell, you will be asked to confirm that you want to exit your 
Windows session.

Using Easy Menu LT

Easy Menu LT is a "lite" version of Easy Menu for Windows.  All its features 
work as described for Easy Menu.  It is different in that many features have been 
removed.  This provides you with a menu application that uses much less memory 
and is easier to use.  Easy Menu LT can be run simultaneously with Easy Menu, and 
can be used to select menus different from those displayed in Easy Menu.   Also, Easy
Menu LT can be run as the system shell.
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3.  Using the Easy Menu Editor

The Easy Menu Editor is used to create, edit, delete and print the menus used 
by Easy Menu.  It is also used to configure certain features of Easy Menu.

The Easy Menu Editor Window

The Editor window has three major parts:  a title bar, a menu bar, and a menu 
listing window.

The Title Bar.  As with all Windows applications, the title bar shows the name
of the application.  The title bar also shows the name of the currently selected group.

The Menu Bar.  The Editor menu bar has four items.  The Group item is used
to select and edit the menu groups.  The Menu item is used to edit and print the 
menu data.   The Options item is used to set various configuration options for Easy 
Menu.  The options include saving the Editor window position and size, setting the 
Windows system shell, specifying an alternate file manager defining the applications 
to start automatically when Windows starts, specifying the initial files to load for the 
desktop accessories, and whether to start Easy Menu with a list of the menus.  The 
About... item displays a dialog box with information about the Easy Menu Editor.

The Menu Listing Window.  The Menu Listing Window shows the menu 
name and item labels for all six of the Easy Menu menus in the currently selected 
group.  Note that if your menu name is long, only the first 20 characters will be 
displayed.  The currently selected menu is outlined with a red border.  The selected 
menu is the one that will be edited when you select the Edit... command, or printed 
when you select the Print Current Menu command.  When the Editor starts, the 
currently active group and menu in Easy Menu will be selected.  To select another 
menu click on the listing with the left mouse button, or move the red selection border
with the arrow keys.

Creating and Editing Groups

To create or edit a group, select Edit Group Names... from the Group menu.
The Menu Group Names dialog box will be displayed.  For each group you want to 
create or edit, simply type the name of the group in the appropriate edit box.  Click 
OK to save the new group names.  (To delete an existing group, just delete the name 
in the edit box.  All the menu data associated with the group is retained so you can 
reenter a group name later to use the group.

To add menus to a new group, select the group from the Group menu.  The 
Menu Listing Window will display six empty menus.  You may now edit any of the 
menus. 

Creating and Editing a Menu

To create or edit a menu, select the menu on the menu listing window.  Click 
the Edit... item from the Menu menu.  The Menu Items... dialog box will be 
displayed.
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Creating a New Menu.  To create a new menu, select  an empty menu in the
menu listing window.  An empty menu will be labeled "Reserved," and have a list of 
10 "Reserved" items.  Select Edit...  from the Menu menu.  The Menu Items... 
dialog box will be displayed.  First, type the name of the menu.  The name will appear
in the Easy Menu Menu pull-down menu and in the Easy Menu for Windows title bar.  
You should make the name descriptive, but not too long.  A maximum of 40 
characters is permitted.

Next, you enter the information for the applications in the menu.  Easy Menu 
for Windows can start up to ten applications in each menu.  Applications are loaded 
according to the information you supply in the Menu Items... dialog box.  For each 
application, you enter a label, a command line, a start-up directory, and whether you 
want the application to start as a window, icon, or full screen.

The label is the name of the application that you want to appear next to the 
button in the menu.  The label can be up to 20 characters long.  For example, the 
label for Microsoft Excel might be MS Excel.

The command line consists of the executable program to be run, and any 
optional parameters.  For example, to run Microsoft Excel, you would enter the 
command line:  excel.exe.  To start Excel with a spreadsheet named "budget.xls" 
loaded on start-up, the command line would be:  excel.exe budget.xls.  The 
command line can be up to 80 characters long.

The start-up directory is the directory you want to use as the working 
directory when the application starts.  For example, if Excel is in the directory "c:\
windows," but your spreadsheets are in a directory called "data" on drive c:, you 
could specify a start-up directory as:  c:\data.  When Excel is started, the "data" 
directory would be active (when you open or save files, for example).  The start-up 
directory is also useful for DOS programs that use configuration files, or for files that 
are in directories that have not been included in your PATH statement.

Finally, select the way you want the application to start:  as a window, an icon,
or as the full screen.  When using a mouse, just click the radio button for your 
selection.  If you are using the keyboard, use the [TAB] key to move to the Start 
as... group, and then use the arrow keys to select the start-up mode.

Use the Next pushbutton to advance to the next menu item.  Enter the data 
for the item, and continue for as many menu items as you want.  When all of the 
menu items have been entered, click the Save button to save your menu data to the 
"menu.ini" file.  The menu data you have entered will be lost if you exit 
without saving it.  After you have saved your data, the Menu Items... dialog box 
will be closed.

Editing an Existing Menu.  To edit an existing menu, select the menu in the 
menu listing window.  Select Edit... from the Menu menu. The Menu Items... dialog
box will be displayed.  Use the Next or Prev pushbuttons to select the menu item 
you want to edit.  Remember, if you are using the keyboard, you can select all the 
pushbuttons by pressing the key corresponding to the letter underlined on the 
pushbutton.  Use the mouse or [TAB] key to position the text cursor to the text you 
want to edit.  To change an existing item you can just retype the new menu data, 
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using the [DELETE] or [BACKSPACE] keys as necessary.  If you change your mind 
about your edit, you can click the Undo button to restore the original text.  
Remember to Save the changes before you exit from the dialog box.

The editor also permits more sophisticated editing of your menus.  In the 
lower right corner of the Menu Items... dialog box are four pushbuttons for special 
editing functions.  With these buttons you can Clear, Insert, and Delete your menu 
items. If you change your mind about an edit, you can Undo all of the editing actions 
since the last Save. 

Clearing an item simply deletes the current text in the edit boxes and replaces
it with the defaults for an empty item.  You click the Clear pushbutton to clear the 
currently displayed item.  Click the Undo pushbutton to restore the text.

Inserting an item moves the items prior to or after the currently selected item 
so that a new menu item can be added to the menu.  How the insert is accomplished 
by the Editor depends on where "Reserved" items remain on the menu -- if 
"Reserved" items are below the inserted item (have a higher item number), the 
existing items are moved down, and the "Reserved" item will be deleted;  if a 
"Reserved" item is above the inserted item (has a lower item number), the items 
above are moved up to fill the "Reserved" item.  You click the Insert pushbutton to 
insert an item.  Click the Undo pushbutton to remove the inserted item and restore 
the menu to its previous order.

Deleting an item removes the currently selected item from the menu, moves 
the items below it on the menu up one position, and inserts an empty "Reserved" 
item at the end of the menu.  You click the Delete pushbutton to delete an item.  
Click the Undo pushbutton to restore the deleted item and move the items below it 
back to their original positions.

Testing the Menu Data.  The Test pushbutton is used to determine if the 
menu information you have supplied can be used by Easy Menu to execute the 
application in the way you intended.  When you click the Test pushbutton the Editor 
performs the following tests:  (1) parses the item label so you can see how it will 
appear on the menu, (2) determines if the command line executable file can be 
found, (3) checks the start-up drive and directory to determine if they actually exist 
on your disk, (4) checks the start-as mode to make sure that an appropriate mode is 
specified in the "menu.ini" file, and (5) parses the command line parameters so you 
can see them in the final test report.  After the test is complete, a report dialog box 
will be displayed.  Any potential errors in your menu data will be reported.  See the 
Troubleshooting section below for an interpretation of each of the error messages. 

Deleting a Menu.  The final editing function in the Menu Items... dialog box
is the Delete Menu pushbutton.  This button is in the upper portion of the dialog 
box, next to the group name.  You use this button to delete an entire menu from the 
"menu.ini" file.  This action cannot be undone, so make sure you really want to delete
a menu before clicking this button.  If you do, you will be asked to confirm the action 
before the deletion takes place.  Click the No button to cancel the delete action.

Printing a Menu

The Easy Menu Editor can print all of the data associated with your menus.  To
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print a menu, select the menu you want to print by clicking on it in the main window 
(or move the selection box with the arrow keys), and select Print Current Menu 
from the Menu menu.  The Editor prints to the default printer for Windows, using the 
current settings for the printer.

Saving the Editor Screen Position

Once you have resized the Editor main window to the size and position you 
like, you can save the position to be used whenever you start the Editor.  Select Save
Editor Position from the Options menu to save the current position and window 
size.

Selecting the System Shell

The sytem shell is the program that runs when you first start Windows.  When 
you installed Windows, Program Manager was set up as the shell.  But you can select 
other programs as shells if you wish.  The System Shell... item in the Options 
menu will configure the shell you want.  If you decide to use Easy Menu for Windows 
3.1 or LT on a regular basis you can set either as the shell.  Click the button for the 
shell you want and then click the OK button.  The shell will be effective the next time 
you start Windows.

Setting Up Applications for Auto Start

If you select Easy Menu or Easy Menu LT as the system shell, you can specify 
that certain applications run when you start Windows.  Five applications can be 
started as full windows and an additional five applications can be started as icons.  To
configure the applications to run, select the Auto Start... item from the Options 
menu.  Enter the program names you want to run and to load as icons.  Remember, if
a program is not in a directory specified in your path statement, you will need to 
enter a complete path and filename in the Auto Start... dialog box (and it's 
preferable to enter the complete path anyway, because the application will load 
faster).  You can move from one field to the next by pressing the [TAB] key.  Click OK
or press the [RETURN] key to save your configuration.

Specifying an Alternate File Manager

Normally, when you click the File Manager button on the Easy Menu manager 
menu, the File Manager shipped with Windows is started.  With Easy Menu you can 
now specify an alternate file manager to start when the File Manager button is 
clicked.  To specify the new file manager,  select File Manager... from the Options 
menu.  The Alternate File Manager dialog box is displayed.  Type the name of the 
new file manager (such as ndw.exe for the Norton Desktop for Windows) and click 
OK.

Setting the Initial Files for Windows Accessories

On some occasions it may be useful to have the Windows Desktop Accessories
load an initial file when they are started.  This is especially useful for an accessory 
such as Calendar, for which you would normally use the same calendar file each time 
it is started.  The Editor can be used to specify the initial file for each of the 
accessories (that can open a file).  To specify files for the accessories, select 
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Accessories... from the Options menu.  The Initial Accessory File... dialog box 
will be diplayed.  For each of the accessories listed, type in the file you want to have 
loaded when the accessory starts.  You can use the [TAB] key to skip down to the 
next item.  You do not have to specify a file for all of the accessories, only for the 
ones you want to open an initial file.  Click the OK pushbutton to save your set-up to 
the "menu.ini" file.  Click Cancel if you want to exit without saving the changes.

To cancel the settings for the initial file, you simply delete the filename 
specified in the Initial Accessory File... dialog box.

Setting Up the User Accessories

The Easy Menu Accessories menu can be configured with either the Windows 
Desktop Accessories or with nine accessories which you define.  To set up your own 
set of accessories, select User Accessories... from the Options menu.  In the 
dialog box that is displayed, you enter the name to appear on the face of the 
pushbutton and the command line to be executed when the button is pushed.  The 
command line can consist of the executable file name plus any command line 
parameters.  When Easy Menu starts accessories it assumes they are in your 
Windows directory, and you should normally put accessories in that directory.  If your 
accessories are elsewhere, you will have to include the path as a part of the 
command line; the accessory will start, but the Windows directory will remain active.

Note that each accessory you define is assigned to one of nine function keys.  
When the Accessories pushbutton menu is active in Easy Menu, you can use the 
assigned function key to start the accessory.

Once you have defined all of the accessories, click the OK pushbutton.  To use
the accessories you have defined, return to Easy Menu, update the menus by clicking
the U pushbutton in the Command Bar, and select User Accessories from the 
Options menu.

Listing Menus on Start-up

If you use a large number of applications on the six menus you may want to 
start Easy Menu with the list of menus instead of with Menu 1.  You can make the 
Select Menu... dialog box in Easy Menu display automatically on start-up by 
selecting List Menus on Start from the Options menu.  A checkmark will appear 
next to this option if it  has been selected.  To turn off the option, select List Menus 
on Start again.

Exiting from the Editor

To exit the editor, select Exit from the Group menu or double-click the system
box.
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4.  Troubleshooting
Easy Menu 3.2 provides for complete error checking and reporting.  Error and 

informational messages will be displayed when a command or other action cannot be
successfully completed.  Listed below are the Easy Menu and Easy Menu Editor error 
messages, the likely cause for each error, and the possible solutions to the problems.

Easy Menu Error Messages

Too many clocks or timers.

This error means that too many programs which use the Windows timer (such 
as the Clock) are currently running.  Easy Menu needs one of the timers to display 
the current date and time.  Close one of the applications and try to restart Easy 
Menu.

The specified start-up directory is invalid.

The start-up directory that you entered for the application does not exist.  You 
may have misspelled it when entering it.  Use the Easy Menu Editor to change the 
start-up directory to a valid DOS directory.

The specified start-up drive is invalid.

You specified a disk drive in the start-up directory that does not exist.  Use the
Easy Menu Editor to change the start-up drive to a vaild drive on your system.

Insufficient memory to run application.

There is not enough memory to run the application.  If other applications are 
running, try closing some of them to free some memory.

Invalid path or filename.

The path or filename that you specified in the command line is invalid.  You 
may have misspelled it.  Use the Easy Menu Editor to enter the correct path and 
filename for the application you want to run.

Unable to execute application.

Easy Menu has encountered some problem while trying to execute the 
application.  Close other applications, and be sure your command line is correct.

Unable to execute accessory.

Easy Menu has encountered some problem while trying to execute an 
accessory.  If the accessory is a Windows Desktop Accessory, it probably is not in the 
Windows directory; be sure the accessories are properly installed in the Windows 
directory.  If it is a user accessory, you may have misspelled the accessory program 
name when setting it up or it is not in the Windows directory; use the menu editor to 
check the information you supplied and enter a path in the command line if 
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necessary. 
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Program Manager is already running.

You tried to start the Program Manager when it was already running.  Use the 
Task List to activate the Program Manager.

File Manager is already running.

You tried to start the File Manager when it was already running.  Use the Task 
List to activate the File Manager.

Incorrect license number entered.

The license number you entered was not valid.  Be sure you typed the number
exactly as listed on the registration notification.  Contact the author if the your 
license cannot be entered.

Invalid password after three attempts.  Cancelling current task. 

The password has been entered incorrectly three times.  After the third try, 
Easy Menu cancels the requested task.

Invalid password.  Cannot start Easy Menu 3.1.

Password protection has been applied to Easy Menu start-up and the correct 
password was not entered.  Easy Menu cannot be started.

Easy Menu Editor Not Found.

The file "menuedit.exe" could not be found.  This file must be in the Windows 
directory.  Contact the author if the file is not included in the distribution ZIP file you 
are using.

Selected drive is removable.  Please insert diskette now.  

You have requested a file operation for a diskette drive (a: or b:).  This is a 
reminder to be sure a diskette is in the drive.

File has no text and cannot be viewed.

You tried to view an empty file.  The viewer will work only with a valid ASCII 
text file.

Source file cannot be opened.  File operation halted.

Easy Menu could not find or could not open the specified file.  You may need 
to specify a full path the file or make sure it is not read-only.

Cannot copy or move a file to itself.  Select a new Target Directory.

You tried to copy a file but did not change the target directory.  Change the 
directory you are to copy the file to.
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File already exists in Target Directory.  Overwrite existing file?

This message is asking for confirmation to overwrite a file with the same file 
name as the one you are copying or moving.

Target file cannot be created.  File operation halted.

Easy Menu was unable to create the file you specified.  Check to make sure it 
was a valid DOS filename, or that your disk is not full.

File could not be deleted.

Easy Menu was unable to delete the file you specified.  Make sure you 
specified the file name correctly and that the file is not read-only.

File cannot be opened for viewing.  View operation halted.

Easy Menu could not open the specified file.  Make sure you specified the file 
name correctly and that it is in the current directory.

Directory could not be created.

Easy Menu could not create the new subdirectory you requested.  Make sure 
that you specified a proper DOS directory name and that the directory does not 
already exist on the specified drive.

Easy Menu Editor Error Messages

Cannot access printer driver.

This error occurs if the Easy Menu Editor is unable to determine the type of 
printer you are using.  This information is contained in the "win.ini" file under the 
[Windows] section in a field labeled "devices=."  Use the Control Panel to set up a 
default printer.

Unable to start print job.

The Easy Menu Editor was unable to initialize the printer spooler.  Be sure that
the Print Manager is properly installed.

Are you sure you want to delete the menu: _________.

This is an informational message requesting confirmation before deleteing a 
menu.  This action cannot be undone, so only delete a menu if you are sure you no 
longer need it.

You do not need to insert.  The item is available for use.

You tried to insert when the current item is Reserved.  You do not need to 
insert.
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Cannot insert. This menu is full.

You tried to insert a menu item in a full menu.  Only ten items can be listed in 
each menu.  Delete an item in the current menu, or try to insert in another menu with
"Reserved" items.
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Problem Reporting

Please report any problems or suggestions for improvements to the following address
or contact the author on Compuserve:  71401,2413.

Glen S. Tittermary
P.O. Box 1641
Richmond, Virginia 23213
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